Chakra | Foro

Foro oficial de la comunidad hispana de Chakra

No estas registrado.

Anuncio

#1 17-08-2015 19:10:39

azkanel
Miembro
Registrado: 17-08-2015
Mensajes: 7

libGL error: open uki failed (Operation not permitted) (SOLUCIONADO)

Este tema ya está en el otro foro en inglés, pero parece que están preparando otros cambios y no tienen tiempo para esto ahora mismo. La cosa está en qué opciones hay antes de instalar windows u otras distribuciones, ya uqe me estaba planteando cambiara mint kde que no da tantos problemas.
He pensado en el driver libre, pero hace bastantes meses que no lo actualizan y no va muy fino o cambiar a catalyst-lts, cosa que he hecho en un principio y me ha instalado el kernel linux-lts, pero la cosa que catalyst-libgl me lo ha instalado de la versión 15.5 y lib32-catalyst no lo instala y sería necesario.
¿Alguien podría decirme cómo instalar catalyst-lts correctamente y que funcione bien?, si hace falta instalar el kernel linux lts tambien, pero no se como pasar a usarlo, ¿no hay un lib32-catalyst y un catalyst-libgl que sean lts?
Otra opción tal vez sería instalar la versión 15.7 que en el otro foro también lo comentaban, pero si hubiera alguna indicación más específica de como hacerlo se agradece, jeje

Gracias.

P.D.: Tengo dos ordenadores con gráficas amd, 8400 y 7870 y con las dos igual, no puedo jugar a más de sesenta juegos que tengo en steam. Llevo más de dos años en chakra contento, pero de verdad, hay veces que esto molesta bastante y da por abandonar. ¿No podrían haver pensado en este fallo antes de actualizar las versiones de catalyst y kernel?


Actualización:
Me respondo yo mismo que después de más de dos días de desesperación sin respuesta y haciendo decenas de pruebas he conseguido instalar catalyst-test 15.7 desde AUR de Arch Linux y funciona aparentemente todo, ningún error aparente, todo funciona XD.
Aún así estaría bien poder saber si hay algún tutorial de cómo instalar linux-lts y catalyst-lts.

Ultima edición por azkanel (23-08-2015 13:49:02)

Desconectado

#2 21-08-2015 20:26:37

paran0id
Administrador
Registrado: 17-04-2015
Mensajes: 31

Re: libGL error: open uki failed (Operation not permitted) (SOLUCIONADO)

Hola!!

Perdona la demora, es que estoy de vacaciones y ya sabes... big_smile

Yo he probado todo, instalar el lts, drivers libres, actualizar catalyst con el driver de la web de AMD y nada... Pero lo de usar linux-lts me parece que tienes que cambiar la config de grub para que lo use al inicio del sistema:

http://chakraos.org/forum/viewtopic.php … 113#p40113

Por otro lado, dijeron que los drivers libres los actualizarían, pero hace poco actualzaron linux pero los drivers no xD

¿Qué manual has seguido para instalar los drivers por AUR? Lo que me echa un poco atrás ese tema, es que no sé si luego habrá problemas con las actualizaciones oficiales...

Saludos!

Desconectado

#3 21-08-2015 21:01:22

azkanel
Miembro
Registrado: 17-08-2015
Mensajes: 7

Re: libGL error: open uki failed (Operation not permitted) (SOLUCIONADO)

Pues el linux-lts parece ser que era un problema con el paquete que ya han puesto una actualización en el repositorio testing.
Lo de catalyst-lts sigo teniendo mis dudas, por eso digo de ver como se instala correctamente el catalyst-lts proque sólo se me instala en lts el principal y el resto el 15.5, por lo que me da fallo.

Lo de AUR es algo temporal hasta que los paquetes oficiales los corrigan y funcionen. En AUR me descargo el paquete build de la web AUR https://aur.archlinux.org/cgit/aur.git/ … est.tar.gz se guarda, descomprime y dentro: $makepkg PKGBUILD y automáticamente genera el archivo de instalación y con $pacman -U catalyst-test-15.7-1-x86_64.pkg.tar.xz se instala y funciona a la perfección.



¡uff!!, ha sido un tremendo alivio para mi, jejeje

Ultima edición por azkanel (21-08-2015 21:01:42)

Desconectado

#4 21-08-2015 22:37:47

paran0id
Administrador
Registrado: 17-04-2015
Mensajes: 31

Re: libGL error: open uki failed (Operation not permitted) (SOLUCIONADO)

Igual también los paquetes de catalyst-lts tienen problemas... Pero hasta que arreglen todo creo pasará mucho xD

Pues voy a probar con lo del paquete AUR a ver si me funciona a mí, muchas gracias por el consejo!! Que yo también estoy que me arranco los pelos por no poder usar Chakra big_smile

Saludos!

EDITO: Funciona perfecto! De momento podemos dejar el tema solucionado con un gran asterisco big_smile

Desconectado

#5 23-08-2015 13:48:34

azkanel
Miembro
Registrado: 17-08-2015
Mensajes: 7

Re: libGL error: open uki failed (Operation not permitted) (SOLUCIONADO)

Vale, aunque me da sensación de que el refresco de pantalla o algo parecido no va del todo fluido, pero vaya, que puedo volver a usar chakra para mis juegos, jejeje

Ultima edición por azkanel (23-08-2015 13:49:31)

Desconectado

Pie de página

Powered by FluxBB